wordpressに使うテーマテンプレートには気を付けたい

  • このエントリーをはてなブックマークに追加
  • Pocket
  • LINEで送る
wordpressテーマエラー

このブログはワードプレスで作られています。とても気になった記事なのでメモ。

無料のWordPressテーマをググって使うのは超ハイリスクなので気をつけよう!

とても有益な情報でした。

wordpressを使っていると外国のサイトからテーマやプラグインをインストールするっていうことがよくあります。

ググってほかの人も使っているから大丈夫みたいな感じで安心しきっていたのですが、この記事を見て心配になったので自分でも検討してみようと負いました。

プラグインをインストールして検証。

1つでてきた。怖い。base64_decode関数でエンコードされた文字がつらつらと出てきて、なんだかいろいろな関数が組み込まれてた。

やっぱり危ないんだなと実感。

使う前に一度ローカル環境で検証した方がいいと実感。そして、プラグインやテーマはいつでも最新の状態にしておくというのは鉄則のようです。

しかし、今現在使っているテーマは自動アップデートがされてない。激変したwordpress2から3への移行も何もなかった。きっと作者が更新してないからだと思いますが、自分で挿入したコードが大丈夫かというのも心配なのでプラグインをインストールして検証してみました。

そうしたら、たくさん出てきた。

wordpressテーマエラー

非推奨のテンプレートタグをつかってたり、自分でカスタマイズしたところが間違ってたりと、これから少しずつ直していきたいと思います。

  • このエントリーをはてなブックマークに追加
  • Pocket
  • LINEで送る

SNSでもご購読できます。

コメントを残す

*

CAPTCHA